Wearable tech Powered by Trendolizer

watchOS 5 won’t support first gen Apple Watches, including $17,000 Editions

Trending story found on 9to5mac.com
watchOS 5 won’t support first gen Apple Watches, including $17,000 Editions
After announcing watchOS 5 today, Apple has shared the hardware requirements for the latest operating system for its wearables.
[Source: 9to5mac.com] [ Comments ] [See why this is trending]

Trend graph:

Comments